SetMappingInfo(IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo>) Method


IFCCategory Template Set Mapping Info(IDictionary Export IFCCategory Key, Export IFCCategory Info ) Method

Set the mapping info for multiple keys.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMappingInfo(
	IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> newMap
)

Parameters

newMap IDictionary ExportIFCCategoryKey , ExportIFCCategoryInfo
The updated map.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also