AddStackedItems Method (RibbonItemData, RibbonItemData)


Ribbon Panel Add Stacked Items(Ribbon Item Data, Ribbon Item Data) Method

Adds two stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<RibbonItem> AddStackedItems(
	RibbonItemData item1,
	RibbonItemData item2
)

Parameters

item1 RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
item2 RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.

Return Value

IList RibbonItem
A collection containing the added items.
Exceptions
Exception Condition
ArgumentNullException Thrown when item1 or item2 is .
ArgumentException Thrown when an item with the item1.Name or item2.Name already exists in the panel or the data is not of the correct type.
Remarks
Each new item may either be a PushButton, PulldownButton, SplitButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.
See Also