ExclusionFilter Constructor


Exclusion Filter Constructor

Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExclusionFilter(
	ICollection<ElementId> idsToExclude
)

Parameters

idsToExclude ICollection ElementId
The ids to exclude from the results.
Exceptions
Exception Condition
ArgumentException The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException A non-optional argument was null
See Also