CurveByPointsUtils Class


Curve By Points Utils Class

A static class that contains methods for processing curves driven by points.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveByPointsUtils : IDisposable

The CurveByPointsUtils type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member AddCurvesToFaceRegion Adds The CurveElements to one or more FaceRegions.
Public method Static member CreateArcThroughPoints Creates an arc through the given reference points.
Public method Static member CreateRectangle Creates rectangle on face or sketchplane for two given diagonal points.
Public method Dispose Releases all resources used by the CurveByPointsUtils
Public method Static member GetFaceRegions Gets the FaceRegions in the existing face.
Public method Static member GetHostFace Gets the host face to which the CurveElement is added.
Public method Static member GetProjectionType Gets the projection type of the CurveElement.
Public method Static member GetSketchOnSurface Gets the relationship between the CurveElement and face.
Public method Static member SetProjectionType Sets the projection type of the CurveElement.
Public method Static member SetSketchOnSurface Sets the relationship between the CurveElement and face.
Public method Static member ValidateCurveElementIdArrayForFaceRegions Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.
Top
See Also