GetSpatialElementFromToCalculationPoints Method


Family Instance Get Spatial Element From To Calculation Points Method

Gets the locations for the calculation points for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<XYZ> GetSpatialElementFromToCalculationPoints()

Return Value

IList XYZ
A list of 3d points.
Exceptions
Exception Condition
InvalidOperationException Thrown if this instance does not have from/to calculation points..
Remarks

For a family instance which connects two rooms or spaces, such as a door or window, the points determine which room or space is considered the "from" and which is considered the "to".

See Also