CreateReferenceElevationMarker Method


Elevation Marker Create Reference Elevation Marker Method

Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElevationMarker CreateReferenceElevationMarker(
	Document document,
	ElementId viewFamilyTypeId,
	XYZ origin,
	ElementId viewPlanId
)

Parameters

document Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin XYZ
The desired origin for the ElevationMarker.
viewPlanId ElementId
The ViewPlan in which the reference ElevationMarker will appear. Reference ElevationMarkers only appear in one view.

Return Value

ElevationMarker
The new ElevationMarker.
Exceptions
Exception Condition
ArgumentException The ElementId viewPlanId does not correspond to a ViewPlan. -or- This view family type is not appropriate for ElevationMarkers. -or- Elevation view creation is not allowed in this family.
ArgumentNullException A non-optional argument was null
See Also