SetRuleEnabled Method (PerformanceAdviserRuleId, Boolean)


Performance Adviser Set Rule Enabled(Performance Adviser Rule Id, Boolean) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetRuleEnabled(
	PerformanceAdviserRuleId id,
	bool enabled
)

Parameters

id PerformanceAdviserRuleId
The rule id to set enabled/disabled status for.
enabled Boolean
True enables the rule, false disables.
Exceptions
Exception Condition
ArgumentException The id does not correspond to any registered rule.
ArgumentNullException A non-optional argument was null
See Also