OptimizeLengths Method


Fabrication Part Optimize Lengths Method

Optimizes the length fabrication straight parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> OptimizeLengths(
	Document document,
	ISet<ElementId> partIds
)

Parameters

document Document
The document.
partIds ISet ElementId
The identifiers of the fabrication parts in a selected fabrication part run.

Return Value

ISet ElementId
New and modified fabrication part ids in the optimize
Exceptions
Exception Condition
ArgumentException There are no straight parts to optimize, or all parts are locked or locked by group membership.
ArgumentNullException A non-optional argument was null
InvalidOperationException this operation failed.
See Also