Loss |
This class is the base class for calculating lighting loss factor.

System Object
Autodesk.Revit.DB.Lighting LossFactor
Autodesk.Revit.DB.Lighting AdvancedLossFactor
Autodesk.Revit.DB.Lighting BasicLossFactor
Autodesk.Revit.DB.Lighting LossFactor
Autodesk.Revit.DB.Lighting AdvancedLossFactor
Autodesk.Revit.DB.Lighting BasicLossFactor
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LossFactor type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LossFactorValue | The calculated loss factor value |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LossFactor derived object. |
![]() | Dispose | Releases all resources used by the LossFactor |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |