Duplicate Method (SheetDuplicateOption)


View Sheet Duplicate(Sheet Duplicate Option) Method

Duplicates this sheet to generate a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId Duplicate(
	SheetDuplicateOption duplicateOption
)

Parameters

duplicateOption SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

ElementId
The id of the newly created sheet.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Sheet cannot be duplicated
See Also