AnalyticalNodeData Class


Analytical Node Data Class

This class holds information related to analytical model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure AnalyticalNodeData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalyticalNodeData : IDisposable

The AnalyticalNodeData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalyticalNodeData
Public method Static member GetAnalyticalNodeData Returns AnalyticalNodeData associated with this element, if it exists.
Public method GetConnectionStatus Returns the Connection Status for this Analytical Node.
Top
Remarks
This class is attached to a ReferencePoint.
See Also