ElementLevelFilter Constructor (ElementId, Boolean)


Element Level Filter(Element Id, Boolean) Constructor

Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementLevelFilter(
	ElementId levelId,
	bool inverted
)

Parameters

levelId ElementId
The id of the level that will be matched to elements' associated level.
inverted Boolean
True if the filter should match all elements not associated to the given level.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also