HasEnded Method


Sub Transaction Has Ended Method

Determines whether the sub-transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool HasEnded()

Return Value

Boolean
True if the sub-transaction has already been committed or rolled back, False otherwise.
Remarks
A sub-transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a sub-transaction has ended is by testing its current status returned from (see GetStatus ). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'
See Also