GetAdjacentRegions Method


Compound Structure Get Adjacent Regions Method

Gets the ids of region bound to a specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<int> GetAdjacentRegions(
	int segmentId
)

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

IList Int32
The ids of the regions that are bounded by the specified segment.
Exceptions
Exception Condition
ArgumentException The segment id is invalid.
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids. The segments which define the outer boundary of the structure are adjacent to one region, other segments will be adjacent to two regions.
See Also