Origin Property


Connector Origin Property

The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual XYZ Origin { get; set; }

Property Value

XYZ

Implements

IConnector Origin
Exceptions
Exception Condition
InvalidOperationException Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
ArgumentException Thrown when the assigned origin is invalid.
InvalidOperationException Thrown on failure to set origin.
Remarks
Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.
See Also