Routing |
A class representing a rule set in MEP routing preferences.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RoutingPreferenceRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description. |

Name | Description | |
---|---|---|
![]() | Description | The description of the routing preference rule. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule. |
![]() | NumberOfCriteria | Gets the number of routing criteria. |
![]() | RoutingPreferenceManager | Gets the routing preference manager that owns this rule. |

Name | Description | |
---|---|---|
![]() | AddCriterion | Adds a new routing criterion. |
![]() | Dispose | Releases all resources used by the RoutingPreferenceRule |
![]() | GetCriterion | Gets the specified criteria. |
![]() | RemoveCriteron | Removes an existing criterion. |