RevitLinkOperations Class


Revit Link Operations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LinkOperations
Autodesk.Revit.DB RevitLinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitLinkOperations : LinkOperations

The RevitLinkOperations type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LinkOperations )
Top
Methods
Name Description
Public method Dispose
(Inherited from LinkOperations )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetGetLocalPathForOpenCallback Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.
Public method SetOnLocalLinkSharedCoordinatesSavedCallback Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
(Inherited from LinkOperations )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

The class owns single-method interfaces which are used as callbacks to perform specific operations on Revit link external resources.

An empty RevitLinkOperations instance is passed to an IExternalResourceServer (inside an ExternalResourceServerExtensions object) via the GetTypeSpecificServerOperations method. The server provider can then add their own implemented interface objects to the RevitLinkOperations, thus making them available to Revit to use as callbacks.

Supporting these additional, type-specific operations is not absolutely required, but is strongly recommended in order for users to be able to perform all the same operations they would with locally-accessed Revit links.

See Also