ModuleSettings Class


Module Settings Class

The module settings.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Macros ModuleSettings

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ModuleSettings : IDisposable

The ModuleSettings type exposes the following members.

Constructors
Name Description
Public method ModuleSettings Constructs a new module settings.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MacroLanguageType The Macro language type.
Public property Name The module name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ModuleSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also