Create Method


Point Cloud Type Create Method

Creates a new point cloud type for a given point cloud engine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PointCloudType Create(
	Document document,
	string engineIdentifier,
	string typeIdentifier
)

Parameters

document Document
The document in which to create the point cloud.
engineIdentifier String
The string identifying the engine to be invoked. It should be the file extension or engine identifier registered by the third party.
typeIdentifier String
The file name or the identification string for a non-file based engine.

Return Value

PointCloudType
The newly created PointCloudType object to be used to create instances of this point cloud.
Exceptions
Exception Condition
ArgumentException The engine identifier was not found in the Revit session. -or- document is not a project document.
ArgumentNullException A non-optional argument was null
FileNotFoundException The external file could not be found or loaded.
InvalidOperationException Unable to create a point cloud from the third party engine.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
A list of supported engine identifiers and whether they are file-based or not can be obtained from PointCloudEngineRegistry. The method GetSupportedEngines() returns a list of the identifiers registered for engines.
Example
private PointCloudInstance CreatePointCloud(Document doc)
{
    PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
    return (PointCloudInstance.Create(doc, type.Id, Transform.Identity));
}
See Also