RebarHostData Class


Rebar Host Data Class

Interface to rebar-specific data stored in each valid rebar host element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarHostData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarHostData : IDisposable

The RebarHostData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarHostData
Public method GetAreaReinforcementsInHost Returns all AreaReinforcement elements hosted by the referenced element.
Public method GetCommonCoverType If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return .
Public method GetCoverType Gets the CoverType associated with a face of the element.
Public method GetExposedFaces Returns all the exposed faces, that is, those that have an associated CoverType.
Public method GetFabricAreasInHost Returns all FabricArea elements hosted by the referenced element.
Public method GetFabricSheetsInHost Returns all FabricSheet elements hosted by the referenced element.
Public method GetPathReinforcementsInHost Returns all PathReinforcement elements hosted by the referenced element.
Public method GetRebarContainersInHost Returns all RebarContainer elements hosted by the referenced element.
Public method Static member GetRebarHostData Gets a RebarHostData object referring to the specified rebar host element.
Public method Static member GetRebarHostDirectNeighbors Returns a set of ElementIds for Elements joined to the provided host element.
Public method GetRebarsInHost Returns all Rebar elements hosted by the referenced element.
Public method IsFaceExposed Checks whether the specified face is considered exposed, and therefore has an associated CoverType.
Public method Static member IsReferenceContainedByAValidHost Identifies whether an element that contains the given reference can host reinforcement.
Public method IsValidHost Reports whether the element is a valid rebar host.
Public method Static member IsValidHost(Element) Identifies whether a given element can host reinforcement.
Public method SetCommonCoverType Associate a single CoverType with all exposed faces of the host element.
Public method SetCoverType Associates the specified CoverType with the specified face of the element.
Top
Remarks

Rebar host elements keep track of the "exposed faces," those that are not completely concealed by another rebar host. Faces may be concealed by joins; for instance, the top face of a beam that supports a slab is concealed. Faces can also be concealed by adjacency; for instance, the bottom face of a column that is supported by a foundation. Each exposed face of a rebar host must have a valid CoverType associated with it.

Rebar hosts also have cover parameters, providing a limited interface to the GetCoverType and SetCoverType methods. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host.

  • CLEAR_COVER_EXTERIOR (walls only)
  • CLEAR_COVER_INTERIOR (walls only)
  • CLEAR_COVER_OTHER (all hosts except in-place families and stairs)
  • CLEAR_COVER (in-place families and stairs)
  • CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs)
  • CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs)
See Also