GenerateCurves Method


IRebar Update Server Generate Curves Method

This function is supposed to calculate the bars in set based on data received in curvesData parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
bool GenerateCurves(
	RebarCurvesData curvesData
)

Parameters

curvesData RebarCurvesData
Use the members of this class to access the inputs and define the output curves that make up the free form rebar.

Return Value

Boolean
Returns true if the curve generation was successful, false otherwise.
Remarks
This function is called in the regeneration context when at least one data in curvesData parameter was changed.
See Also