Add Method


Mechanical Equipment Set Add Method

Adds member element ids to the mechanical equipment set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Add(
	ISet<ElementId> elemIds
)

Parameters

elemIds ISet ElementId
Element ids to be added to the mechanical equipment set.
Exceptions
Exception Condition
ArgumentException The valid members must have the same classification and system. They cannot be a member of existing set. -or- These elements are serially connected with each other, or with one of the set members.
ArgumentNullException A non-optional argument was null
See Also