GetCoordinate Method


Repeater Coordinates Get Coordinate Method

Returns the coordinate in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetCoordinate(
	int dimension
)

Parameters

dimension Int32
The dimension.

Return Value

Int32
The coordinate.
Exceptions
Exception Condition
ArgumentException The dimension is invalid for these coordinates.
InvalidOperationException The coordinates must have at least one dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional coordinates.
See Also