Formatted |
Returns the indent level of the paragraphs in the text range.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- textRange TextRange
- The given text range.
Return Value
Int32The indentation level of the paragraphs in the range.

Exception | Condition |
---|---|
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
ArgumentNullException | A non-optional argument was null |

Returns -1 if the range contains multiple paragraphs with different indent levels.