GetAllElements Method


Sketch Get All Elements Method

Returns all elements which belong to the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> GetAllElements()

Return Value

IList ElementId
Returns ids of elements which belong to that sketch.
Remarks
Following elements can belong to a sketch: ModelCurve , ReferencePlane , Dimension . To get matching between Curve from Profile and ModelCurve , use [!:Autodesk::Revit::DB::Curve::Reference::ElementId] .
See Also