ObjectType Enumeration


Object Type Enumeration

This enumerated type contains object types allowed to be selected during selection operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ObjectType
Members
Member name Value Description
Nothing 0 Nothing.
Element 1 Whole element.
PointOnElement 2 Any point on an element (on a face or curve).
Edge 3 Any model edge.
Face 4 Any face.
LinkedElement 5 Elements in linked RVT files.
Subelement 6 Whole element or subelement.
See Also