SetExtendableRegionIds Method


Compound Structure Set Extendable Region Ids Method

Sets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetExtendableRegionIds(
	bool top,
	IList<int> regionIds
)

Parameters

top Boolean
If true, set ids of regions which are extendable at the top, otherwise set the ids of regions which are extendable at the bottom.
regionIds IList Int32
The ids of regions which will be extendable.
Exceptions
Exception Condition
ArgumentException The region ids are not valid.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
Regions along the top or bottom of the wall may be set to be extendable.
See Also