BuiltInFailures.RebarFailures Class


Built In Failures Rebar Failures Class

Failures about Rebar.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures RebarFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarFailures

The BuiltInFailures RebarFailures type exposes the following members.

Properties
Name Description
Public property Static member BarDiameterTooLarge Rebar Bar Diameter is too large.
Public property Static member BarTypeDoesNotAllowHooksOfCurrentShape You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
Public property Static member BendDiameterTooLarge Rebar Bend Diameter is too large.
Public property Static member BendDiameterTooSmall Rebar Bend Diameter is too small.
Public property Static member CannotCreateFreeFormSetDueToShortBar Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
Public property Static member CannotKeepVariabilityOfRebarInGroup Modifications to the rebar set might cause it to revert to a uniform distribution and reset all disabled constraints. This can occur for layout changes as well as modifications to the geometry.
Public property Static member CannotPlaceRebar Can't find a host for Rebar.
Public property Static member CannotPlaceRebarWarn Can't find a host for Rebar.
Public property Static member CannotSolveRebarShapeUsingDataFromDimension Cannot solve rebar shape using the current constraints.
Public property Static member CannotSolveRebarWithDelayedConstraints There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
Public property Static member CantMakeFillets The bar cannot be bent in that shape. Check the bending diameter and the bar type.
Public property Static member ChangeUnitsFormatWarn The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
Public property Static member ClearPresentationForAllBarsInRebarSet All Bars in a Free Form Rebar Set have been hidden.
Public property Static member ConstraintForHandleIsDisabled The constriant for current handle is disabled.
Public property Static member CoverTooLong Rebar Cover length is too large for host thickness.
Public property Static member DelayedConstraintForHandle The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
Public property Static member HideAllBarsInRebarSet All Bars in Rebar Set have been hidden.
Public property Static member HostTopologyChange A reinforced host has undergone a major change. The reinforcement must be removed.
Public property Static member IncompleteShape Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
Public property Static member InvalidRebarHost Rebar can be placed only in Concrete Structural elements.
Public property Static member InvalidRebarHostFamilyCanHostRebarParam Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
Public property Static member InvalidRebarHostNonConcrete Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
Public property Static member InvalidRebarHostNonStructural Rebar can't be placed in a non-structural element.
Public property Static member InvalidRebarHostWrongCategory Rebar can't be placed in a family of category [Name].
Public property Static member Inverted3dShape The Rebar Shape XX cannot be inverted.
Public property Static member MaxHookExtensionMultiplierWarn The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
Public property Static member MissingCurrentConstraintForHandle The current handle has no constraint. Please select a valid target to apply a new constraint.
Public property Static member NoRebarSelected At least one Rebar should be selected.
Public property Static member NoSurfPatternOnRebar Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
Public property Static member NoVisibleRebarHandle Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
Public property Static member NoVisibleTargetsForCurrentConstraint There are no visible constraint targets in the current view. Please switch to another view.
Public property Static member OutOfPlaneBendDiameterTooSmall The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
Public property Static member OutSideOfHost Rebar is placed completely outside of its host.
Public property Static member PathShapeFailure Can't solve Rebar Shape in Path Reinforcement.
Public property Static member RebarArrayTooShort Rebar Set can't have coincident Bars.
Public property Static member RebarBendRadiusTooBig Rebar Bend Radius is too big. Ignoring bend.
Public property Static member RebarBendRadiusTooBigWarn Rebar Bend Radius is too big. Ignoring bend.
Public property Static member RebarConstraintWarning Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
Public property Static member RebarContainerOutSideOfHostWarning Rebar Container is placed completely outside of its host.
Public property Static member RebarDimensionalConstraintLost Dimensional constraint on Rebar element was lost on upgrade.
Public property Static member RebarEndTreatmentOverHook Cannot set end treatment at an end that has hook.
Public property Static member RebarHookOverEndTreatment Cannot set hook at an end that has end treatment.
Public property Static member RebarHooksDontMatchShape The Rebar's hooks do not match its Rebar Shape.
Public property Static member RebarIllegalBarType There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
Public property Static member RebarInvalidDiameterRemoved Invalid RebarBarType was removed on upgrade.
Public property Static member RebarMovedBarsOverlapped There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
Public property Static member RebarNoConstraints The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
Public property Static member RebarNoMatchingHooks The Rebar Shape '[Family Name]' has no matching hooks.
Public property Static member RebarShapeFailure Can't solve Rebar Shape.
Public property Static member RebarShapeFailureCustomError '[ErrorMessage]'
Public property Static member RebarShapeFailureCustomWarning '[ErrorMessage]'
Public property Static member RebarShapeFailureDueToStaggerOffset Can't solve Rebar Shape using the exisintg stagger offsets.
Public property Static member RebarSpacingTooSmall Bar Spacing is too small.
Public property Static member RebarTooShortImperial The minimum length of rebar shape is 1 inch.
Public property Static member RebarTooShortMetric The minimum length of rebar shape is 25 mm.
Public property Static member RemoveSpliceBetweenBars Splice cannot be maintained.
Public property Static member SketchDimensionsRemoved The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
Public property Static member SketchDimsBWFRemoved The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
Public property Static member SketchFreeFormSet Sketching of a free form set produces only a single bar.
Public property Static member SketchNonPlanarFreeForm The selected free form rebar is not planar. Sketching it will discard the current geometry.
Public property Static member SpliceTypeWasDeleted Splice type was deleted.
Public property Static member StandardHookBendDiameterTooLarge Rebar Standard Hook Bend Diameter is too large.
Public property Static member StandardHookBendDiameterTooSmall Rebar Standard Hook Bend Diameter is too small.
Public property Static member TooLargeNumberOfBars Rebar Set must contain at most 1002 bar locations.
Public property Static member TooSmallNumberOfBars Rebar Set must contain at least two bar locations.
Public property Static member TrySmallerBarType Rebar Bend Diameter is too large. Try a smaller Bar Type.
Public property Static member UnconstrainableRebarHandle The rebar handle does not have any constraint targets.
Top
See Also