Group Show |
Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. -or- This exception is thrown if the input attached detail group cannot be found in the current document. |

Currently, perpendicular elevation views (for example, North and East views) are considered compatible when deciding whether or not to allow a detail group to be displayed in a view. The show operation may generate an error (FailureMessage) based on id if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.