AnalysisDisplayVectorSettings Class


Analysis Display Vector Settings Class

Contains vector settings for analysis display style element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayVectorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayVectorSettings : IDisposable

The AnalysisDisplayVectorSettings type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayVectorSettings Constructs a default instance of vector settings.
Public method AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) Constructs a new copy of the input AnalysisDisplayVectorSettings object.
Top
Properties
Name Description
Public property ArrowheadScale Type of arrow head scaling.
Public property ArrowLineWeight Line weight assigned to arrow lines for vectors.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Rounding Increment to which numeric values of analysis results are rounded in vectors.
Public property TextTypeId Element id of text associated with the settings.
Public property VectorOrientation Vector orientation.
Public property VectorPosition Vector position.
Public property VectorTextType Type of vector text visualization.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalysisDisplayVectorSettings
Public method IsEqual Compares two vector settings objects.
Top
See Also