Divided |
Get a reference to one of the tile surfaces associated with a given seed node.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- gridNode GridNode
- tileIndex Int32
- An integer between 0 and T-1, where T is TilesPerSeedNode .
Return Value
ReferenceA reference to a Face (surface). Returns if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1]. |