Transaction |
Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
TransactionStatusIf finished successfully, this method returns TransactionStatus.RolledBack.

Exception | Condition |
---|---|
InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends. |

Note that once a group is rolled back, the undone transactions cannot be redone.
RollBack can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.