Stairs |
Creates a spiral run in the project document by providing the center, start angle and included angle.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static StairsRun CreateSpiralRun(
Document document,
ElementId stairsId,
XYZ center,
double radius,
double startAngle,
double includedAngle,
bool clockwise,
StairsRunJustification justification
)
Parameters
- document Document
- The document.
- stairsId ElementId
- The stairs that the new stairs run will belong to.
- center XYZ
- The center of the location arc of the spiral run. The Z coordinate of the center is the base elevation for the new run (in model coordinates). It must be greater than or equal to the stairs base elevation.
- radius Double
- The radius of the location arc of the spiral run.
- startAngle Double
- The start angle of the location arc of the spiral run. The angle's coordinate system is world coordinate system which always is XYZ.BasisX and XYZ.BasisY.
- includedAngle Double
- The total angle covered by the spiral run. Must be a positive value (direction is determined by the clockwise flag).
- clockwise Boolean
- True if the spiral run will be created along clockwise direction, False otherwise.
- justification StairsRunJustification
- The location path justification of the new stairs run.
Return Value
StairsRunThe new stairs run.

Exception | Condition |
---|---|
ArgumentException | The stairsId is not a valid stairs element. -or- The given value for startAngle is not finite -or- The input center is not a valid center for spiral run (probably the Z coordinate doesn't meet the restrictions) -or- The includedAngle doesn't satisfy riser restriction to generate spiral run (probably it's too small). |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet. -or- The given value for includedAngle must be positive. -or- A value passed for an enumeration argument is not a member of that enumeration |
ArgumentsInconsistentException | The radius is too small to generate a spiral run at the given justification. |
InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
RegenerationFailedException | The center, radius, startAngle, includedAngle don't satisfy restrictions to generate spiral run. |

The new stairs run and the document will be regenerated. This should be run from within an open transaction.