LeaderShape Property


Leader Leader Shape Property

Geometric style of the leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LeaderShape LeaderShape { get; }

Property Value

LeaderShape
Exceptions
Exception Condition
InvalidOperationException The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.
Remarks
While this property cannot be changed directly, it can change, with limitations, as an effect of other changes to either the leader itself or the annotation element the leader is associated with. For example, straight-line leaders have no elbow points; but if an elbow point is set for a straight leader, which is allowed, it will effectively change the leader's shape to a kinked line.
See Also