BuiltInFailures.DesignOptionFailures Class


Built In Failures Design Option Failures Class

Failures about DesignOptionFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures DesignOptionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DesignOptionFailures

The BuiltInFailures DesignOptionFailures type exposes the following members.

Properties
Name Description
Public property Static member AreaTagLineCannotBeInDesignOption Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
Public property Static member BadReferenceBetweenOptions An element may not reference an element in another Option of the same Option Set.
Public property Static member BadReferenceBetweenOptionsWarn An element may not reference an element in another Option of the same Option Set.
Public property Static member BadReferenceToSecondary No element in a secondary Option can be referenced by an element outside that Option.
Public property Static member BadReferenceToSecondaryWarn No element in a secondary Option can be referenced by an element outside that Option.
Public property Static member CannotAddToOptions Elements can't be added to Option Set
Public property Static member CannotAddToOptionsWarn Elements can't be added to Option Set
Public property Static member CannotPutELAInOption Electrical Load Areas must be in the Main Model.
Public property Static member CannotPutELZInOption Area Based Loads must be in the Main Model.
Public property Static member CannotPutSpaceInOption MEP space must be in the Main Model
Public property Static member CannotPutZoneInOption HVAC Zones must be in the Main Model.
Public property Static member ConfusingHostByElementsInAnotherDesignOption An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingHostByElementsInAnotherDesignOptionWarn An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingHostByElementsInDesignOption An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingHostByElementsInDesignOptionWarn An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingHostByElementsInMainModel An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member ConfusingHostByElementsInMainModelWarn An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInAnotherDesignOption A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInAnotherDesignOptionWarn A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInDesignOption A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInDesignOptionWarn A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInMainModel A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member ConfusingPadByElementsInMainModelWarn A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInAnotherDesignOption A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInAnotherDesignOptionWarn A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInDesignOption A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInDesignOptionWarn A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInMainModel A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member ConfusingSweepByElementsInMainModelWarn A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
Public property Static member DebugLevelsInOptionsError This is an internal diagnostic message.
Public property Static member DebugLevelsInOptionsWarn This is an internal diagnostic message.
Public property Static member ElementsWillBeDeletedNoOption Elements will be deleted
Public property Static member FabricationCannotBeInDesignOption Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
Public property Static member KingNeverInOption A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
Public property Static member KingNeverInOptionWarn A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
Public property Static member MustAddKing In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
Public property Static member MustAddKingWarn In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
Public property Static member MustBeInMainModel Element must be in Main Model
Public property Static member NeverInOption Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
Public property Static member NeverInOptionWarn Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
Public property Static member NoSelectedInOption None of the selected elements can be added to this Option Set. The following warnings provide additional information.
Public property Static member OptionElementsDeleted Elements in [option] were deleted
Public property Static member SelectionIncludesOptionItems Elements that were already in a Design Option were selected. These will not be added to the Option Set.
Top
See Also