Structural |
Defines parameters for Tees shape.

System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionISplitParallelFlange
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionISplitSlopedFlange
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionStructuralTees
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionISplitParallelFlange
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionISplitSlopedFlange
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionStructuralTees
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The StructuralSectionGeneralT type exposes the following members.

Name | Description | |
---|---|---|
![]() | StructuralSectionGeneralT | Creates a new instance of Tees shape. |

Name | Description | |
---|---|---|
![]() | FlangeFillet | Flange Fillet - fillet radius at the flange end. |
![]() | FlangeToeOfFillet | Detailing distance from center of web to flange toe of fillet, in. (mm) |
![]() | SlopedFlangeAngle | Sloped flange angle. (rad) |
![]() | SlopedWebAngle | Sloped web angle. (rad) |
![]() | TopWebFillet | Top Web Fillet - fillet radius at the top of web. |
![]() | WebToeOfFillet | Detailing distance from outer face of flange to web toe of fillet, in. (mm) |

Name | Description | |
---|---|---|
![]() | GetFlangeThicknessInFlangeCenter | Returns thickness of flange measured in the 0.25 * (width - webThickess), sometimes used for sections with width > 300 mm. |
![]() | GetFlangeThicknessInQuarterWidth | Returns thickness of flange measured in the 0.25 * width, sometimes used for sections with width <= 300 mm. |
![]() | GetWebThicknessInHeightCenter | Returns thickness of web measured in the 0.5 * height, |