ToggleButtonData Constructor (String, String)


Toggle Button Data(String, String) Constructor

Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ToggleButtonData(
	string name,
	string text
)

Parameters

name String
The internal name of the new button.
text String
The user visible text seen on the new button.
Exceptions
Exception Condition
ArgumentNullException Thrown when is passed for one or more arguments.
ArgumentException Thrown when an empty string is passed for one or more arguments.
See Also