Appearance |
Finishes the edit scope.
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- updateOpenViews Boolean
- When true, force update of the open views.

Exception | Condition |
---|---|
InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, there is no opened transaction. -or- The editable asset is not valid. |

All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction. If the appearance asset element is used in one or more materials, they will be updated to match any changes made. Open views may not redraw after changes. View update can be forced with the input argument, but doing so can be an expensive operation. Consider using false if immediate update is not needed or if multiple calls to this method are used in a loop.