UnloadItemFiles Method


Fabrication Configuration Unload Item Files Method

Unload the specified fabrication item files from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UnloadItemFiles(
	IList<FabricationItemFile> itemFiles
)

Parameters

itemFiles IList FabricationItemFile
The fabrication item files to unload.
Exceptions
Exception Condition
ArgumentException Fabrication item files can not be unloaded if they are currently in use. -or- Some fabrication item files have not been loaded.
ArgumentNullException A non-optional argument was null
InvalidOperationException The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
See Also