GetCoreBoundaryLayerIndex Method


Compound Structure Get Core Boundary Layer Index Method

Returns the index of the layer just below the core boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetCoreBoundaryLayerIndex(
	ShellLayerType shellLayerType
)

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior return the index on the exterior side (or top side for a roof, floor, or ceiling type). If ShellLayerType.Interior return the index on the interior side (or bottom side for a roof, floor, or ceiling type).

Return Value

Int32
The index of the layer.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
-1 returned if there is no such a layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32) .
See Also