BalusterPlacement Class


Baluster Placement Class

A class which contains information regarding baluster and post placement for a given railing type.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture BalusterPlacement

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BalusterPlacement : IDisposable

The BalusterPlacement type exposes the following members.

Properties
Name Description
Public property BalusterPattern Accesses the object containing properties related to the baluster pattern.
Public property BalusterPerTreadFamilyId The id of baluster per tread family.
Public property BalusterPerTreadNumber The number of balusters per tread.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PostPattern Accesses the object containing properties related to the post pattern.
Public property UseBalusterPerTreadOnStairs If true, one or more balusters will be included on each tread of an associated stair. If false, this is not guaranteed to happen.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BalusterPlacement
Top
See Also