GetReference Method


Steel Element Properties Get Reference Method

This method will return the reference for the given fabrication id.

Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Reference GetReference(
	Document aDoc,
	Guid guid
)

Parameters

aDoc Document
Document in which to search for the reference.
guid Guid
The fabrication id for which a reference is required.

Return Value

Reference
The reference to the element or subelement corresponding to the given id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also