Guid |
Base class of all GUID-based enum classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The GuidEnum type exposes the following members.

Name | Description | |
---|---|---|
![]() | GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value. |


Name | Description | |
---|---|---|
![]() | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Generates a hash code for this Guid-based enum object. (Overrides Object GetHashCode ) |

Reference