FilterIntegerRule Constructor


Filter Integer Rule Constructor

Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilterIntegerRule(
	FilterableValueProvider valueProvider,
	FilterNumericRuleEvaluator evaluator,
	int ruleValue
)

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue Int32
The user-supplied value against which values from a Revit document will be tested.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also