IExternalService Interface


IExternal Service Interface

The base interface class for all external services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExternalService

The IExternalService type exposes the following members.

Methods
Name Description
Public method Execute Implement this method to execute the given server.
Public method GetDescription Implement this method to return a description of the service.
Public method GetName Implement this method to return the name of the service.
Public method GetServiceId Implement this method to return the unique Id of the service.
Public method GetVendorId Implement this method to return the vendor Id of the service.
Public method IsValidServer Implement this method to check if the given instance represents a valid server of this service.
Public method OnServersChanged Implement this method to handle situations when servers for the service have changed.
Public method OnServersDisparity Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.
Top
Remarks

Both supported kinds of services - single-server and multi-server - will derive their classes from this interface, albeit indirectly through an interface specific to the particular kind. External services never derive directly from this class - they always have to derive from either ISingleServerService or IMultiServerService, respectivelly.

See Also