ElementCategoryFilter Constructor (ElementId)


Element Category Filter(Element Id) Constructor

Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementCategoryFilter(
	ElementId categoryId
)

Parameters

categoryId ElementId
The category id to match.
Exceptions
Exception Condition
ArgumentException The category was not valid for filtering.
ArgumentNullException A non-optional argument was null
See Also