StructuralUsage Property


Wall Structural Usage Property

Retrieves or changes the wall's designated structural usage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralWallUsage StructuralUsage { get; set; }

Property Value

StructuralWallUsage
The wall's designated structural usage, such as bearing or non bearing.
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The enum value is not invalid for StructuralWallUsage. -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also