Connector |
Create a new cable tray ConnectorElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ConnectorElement CreateCableTrayConnector(
Document document,
Reference planarFace
)
Parameters
- document Document
- The document to add the connector to.
- planarFace Reference
- The planar face to place the connector on.
Return Value
ConnectorElementThe cable tray ConnectorElement.

Exception | Condition |
---|---|
ArgumentException | The reference is not a planar face. -or- document is not a family document. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Connector creation is not allowed in this family. |

Regenerates the document.