IFCExtrusionCalculatorOptions Class


IFCExtrusion Calculator Options Class

This class contains the options used to calculate extrusions from Revit geometry.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCExtrusionCalculatorOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCExtrusionCalculatorOptions : IDisposable

The IFCExtrusionCalculatorOptions type exposes the following members.

Constructors
Name Description
Public method IFCExtrusionCalculatorOptions Constructs a new instance of a class used to calculate extrusions from Revit geometry.
Top
Properties
Name Description
Public property CustomAxis The custom axis to try (if extrusionAxes includes an option for a custom direction).
Public property ExtrusionAxes The extrusion axes to try when doing the calculation.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Scale The scaling factor for length measurements from the default Revit units to the export units.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCExtrusionCalculatorOptions
Top
See Also