PointOnEdgeFaceIntersection Class


Point On Edge Face Intersection Class

Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PointElementReference
Autodesk.Revit.DB PointOnEdgeFaceIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnEdgeFaceIntersection : PointElementReference

The PointOnEdgeFaceIntersection type exposes the following members.

Properties
Name Description
Public property OrientWithEdge Whether to orient the ReferencePoint to the edge or the face.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetEdgeReference Get a copy of the edge or curve reference.
Public method GetFaceReference Get a copy of the face reference.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetEdgeReference Change the edge or curve reference.
Public method SetFaceReference Change the face reference.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).
See Also